Recommend
1 
 Thumb up
 Hide
7 Posts

Combat Commander: Europe» Forums » General

Subject: Problem with Vassal rss

Your Tags: Add tags
Popular Tags: [View All]
Dan Huffman
United States
Arlington
Virginia
flag msg tools
Supreme Court Listener
badge
Supporter of the National Flag Football League
Avatar
mbmbmbmbmb
Is there a better place to post such a question?

I'm posting it here because I only get the problem when I open CC:E and not when I open Churchill.

I was having a problem with Rails 2.o and someone suggested that I reload Java.
Good news! It worked! Rails 2.0 is working fine.
Bad News! It busted my CC:E Vassal

Whenever I open the CC:E module, it says "Maximum Heap Size Too Large" The maximum heap size stored in your Preferences for this module is too large. In particular, the maximum heap size must be less than the amount of physical RAM in your machine. The failsafe initial heap size of 128MB will be used instead. Please decrease the maximum heap size in your Preferences, and restart VASSAL.


I have 2 Gig in my D: Drive and 19 Gig in my C: Drive, so I think I'm ok on physical space.

... Any ideas???

Again, sorry for posting here, but I looked and there isn't a VASSAL BGG spot for me to post in.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Tanks Alot
United States
Fort Mill
South Carolina
flag msg tools
badge
go2 Youtube Historical Gaming
Avatar
mbmbmbmbmb
go under preferences and double the heap size
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Tim McCarron
United States
Houston
Texas
flag msg tools
badge
Avatar
mbmbmbmbmb
Drive space doesnt matter - its your RAM space that does (Memory in computer) Set the heap to no more than 1024. that should be more than enough for this mod.

If it is still giving you that msg afterwards it is because there is not enough RAM space for Java to create an environment that size, so keep adjusting it down by 128 (from 1024) till you get a value that works
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Antonia
Germany
Wolfsburg
flag msg tools
badge
Avatar
mbmbmbmbmb
Yes, Tim is correct.

The error message is complaining about your RAM size.
RAM != hard disk.

Try the suggestions above, if it still does not work please look up how much RAM you have so that we can help you further.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Dan Huffman
United States
Arlington
Virginia
flag msg tools
Supreme Court Listener
badge
Supporter of the National Flag Football League
Avatar
mbmbmbmbmb
How do I look up my RAM? I have looked on Google and don't get any responses I understand.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Antonia
Germany
Wolfsburg
flag msg tools
badge
Avatar
mbmbmbmbmb
huffman123 wrote:
How do I look up my RAM? I have looked on Google and don't get any responses I understand.
Under Windows you should be able to open the "Properties" tab.
For further information look at this site:
http://windows.microsoft.com/en-us/windows/view-computer-inf...
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Dan Huffman
United States
Arlington
Virginia
flag msg tools
Supreme Court Listener
badge
Supporter of the National Flag Football League
Avatar
mbmbmbmbmb
I reset my computer to factory settings witch I found by following your advice. Now it works. :-)

Thanks to all, though.
3 
 Thumb up
 tip
 Hide
  • [+] Dice rolls