$5.00
$20.00
$15.00
Recommend
5 
 Thumb up
 Hide
2 Posts

Abstract Games» Forums » General

Subject: Benzene (MoHex) 2.0 available rss

Your Tags: Add tags
Popular Tags: [View All]
Eriek Douraan
Mexico
flag msg tools
Benzene, the suite of Hex software that contains the best (as far as I know) Hex AI "MoHex", version 2.0 is available here:

https://github.com/jakubpawlewicz/benzene

Go to the windows/installer directory for instructions on how to install in Windows.

Edit: I didn't make this, I just contacted the authors of a scientific paper they wrote about it and they gave me this link for it. I haven't tried compiling it myself. Didn't intend to mislead anyone. This is the programmer's webpage: http://www.mimuw.edu.pl/~pan/
4 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
David Bush
United States
Radiant
Virginia
flag msg tools
designer
mbmbmbmbmb
Thanks very much for your work! I was going to post an Issue on your Benzene page, but this is most likely a case of me missing something obvious, so I post it here.

My OS is Linux Mint 18, which uses Ubuntu 16.04 repositories. I checked out revision 1371 of fuego as your README file told me. autoreconf -i produced a LOT of warnings but no errors as far as I could tell. For example this warning occurred five times near the start, with the same line numbers each time:

configure.ac:33: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2672: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2689: AC_LINK_IFELSE is expanded from...
configure.ac:33: the top level


Here is what happened with ./configure.

david@Epicurus ~/games/Hex/software/NewMoHex/fuego $ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for ranlib... ranlib
checking for boostlib >= 1.33.1... yes
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking build system type... x86_64-pc-linux-gnu
checking whether the Boost::Thread library is available... yes
configure: error: Could not find a version of the library!


The final two lines are a confusing; it says the Boost::Thread library is available, but it could not find a version. I installed as many relevant boost packages as I could find, but I still get the same error. I should mention that none of the boost packages on my system are labeled with the word "thread." For example, one of them is libboost1.58-all-dev

How should I proceed? Thanks for any clue.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Front Page | Welcome | Contact | Privacy Policy | Terms of Service | Advertise | Support BGG | Feeds RSS
Geekdo, BoardGameGeek, the Geekdo logo, and the BoardGameGeek logo are trademarks of BoardGameGeek, LLC.