Recommend
2 
 Thumb up
 Hide
15 Posts

BoardGameGeek» Forums » BoardGameGeek Related » BGG Bugs

Subject: 10.12.3 Beta 4 Safari - forums, pics blank? rss

Your Tags: Add tags
Popular Tags: [View All]
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
I'm running Apple's OSX 10.12.3 beta 4 and when using Safari, the BGG site is missing content for forums, pictures, the hot list and other similar omitted info.

For example, when going to Arkham Horror LCG, I see no images, no video reviews, no discussions found and so on. When I try the same with Firefox, I do see the site's content. Curious if anyone else is experiencing the same? (and I know, beta software is beta software...just making folks aware this behavior is happening)
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Paul Beasi
United States
Easthampton
Massachusetts
flag msg tools
badge
Avatar
mbmbmbmbmb
I am on 10.12.3 Beta 4 (16D30a) and I'm not experiencing any problems in Safari on my mid-2014 13" MacBook Pro.

1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
I have the same model as well...very odd. I cleared the cache for the BGG site. I had ad-block extensions installed but deactivated. I'll try uninstalling them fully to see if that changes behavior.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
I uninstalled any extensions I had like UBlock, cleared the cache for all BGG-related domains (not just BGG itself), restarted the laptop and still the same. It's puzzling why this is happening. One difference I did see which I can see matters is that this one is a late 2013 model vs 2014.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Paul Beasi
United States
Easthampton
Massachusetts
flag msg tools
badge
Avatar
mbmbmbmbmb
I use AdGuard Premium as well as Disconnect and they are both active and not causing any problems that I can see. I do use the "more space" resolution setting so for kicks I tried setting it back to the standard resolution and that didn't change anything.
1 
 Thumb up
1.00
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
I guess I'll wait to see if anything happens with beta 5 as I'm out of ideas on this end. FWIW, this is a pic of what I'm seeing.




Thanks for helping with this anyway, appreciate it.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Paul Beasi
United States
Easthampton
Massachusetts
flag msg tools
badge
Avatar
mbmbmbmbmb
Wow that is truly bizarre. Does anything happen if you try to see all 999,999 forum threads? wow

1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Jim Cote
United States
Maine
flag msg tools
badge
Avatar
mbmbmbmbmb
Open your developer tools console, reload the page, and post a screenshot of that.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
seqiro wrote:
Wow that is truly bizarre. Does anything happen if you try to see all 999,999 forum threads? wow



Nothing appears Just more blank space.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
ekted wrote:
Open your developer tools console, reload the page, and post a screenshot of that.


This what you mean Jim?



Edit: to make this further bizarre, I just installed Chrome and am seeing the same behavior with forums being blank, etc... But Firefox appears to be working fine.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Paul Beasi
United States
Easthampton
Massachusetts
flag msg tools
badge
Avatar
mbmbmbmbmb
Now it looks like you have a certificate problem for geekdo.com. If I just go to https://geekdo.com, I do get a certificate mismatch error because the certificate is for boardgamegeek.com. You could try going there in Safari and trusting the certificate to see if that helps.

Edit: This would make sense because Safari and Chrome both use Keychain for certificates while FireFox does not.
1 
 Thumb up
1.00
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
seqiro wrote:
Now it looks like you have a certificate problem for geekdo.com. If I just go to https://geekdo.com, I do get a certificate mismatch error because the certificate is for boardgamegeek.com. You could try going there in Safari and trusting the certificate to see if that helps.

Edit: This would make sense because Safari and Chrome both use Keychain for certificates while FireFox does not.


Thanks for the suggestion. I just tried it in Safari (then Chrome) and I too get that cert error. I trusted it but no luck. That theory was a great idea too!
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Paul Beasi
United States
Easthampton
Massachusetts
flag msg tools
badge
Avatar
mbmbmbmbmb
I feel like we can figure this out! The console clearly shows that it isn't loading the resources due to a certificate problem.

Can you launch Keychain Access, go to Certificates, and look at the boardgamegeek.com certificate for something unusual? Mine looks like this:

1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
I agree Paul!

The settings for the BGG cert if Keychain Access looks like yours. I will see if I can delete it to help reset it.

Edit: No luck with the above. I deleted the cert, shutdown Safari and tried to hit BGG but same problem.

Here's a pic of an images page using Chrome with the dev tools console on the right:

 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Bob Bergeron
United States
North Smithfield
Rhode Island
flag msg tools
badge
Avatar
mbmbmbmbmb
I just tried something and wanted to share in case made sense to others. In Safari, I displayed the error console. When I go to a game page and see the blank entries for forums, etc...I see the errors in red that I previously uploaded. When I click on one of those error urls (api.geekdo.com), a cert confirmation box appears and when I confirm then what appears like raw data from the url shows.

But - when I then go back to the game page, the forums, pictures, etc...magically appear. This remains true for other game pages. As expected, went I close Safari, the certificate issue re-appeasrs and the portions of the games page are blank again.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Front Page | Welcome | Contact | Privacy Policy | Terms of Service | Advertise | Support BGG | Feeds RSS
Geekdo, BoardGameGeek, the Geekdo logo, and the BoardGameGeek logo are trademarks of BoardGameGeek, LLC.