Recommend
3 
 Thumb up
 Hide
11 Posts

BoardGameGeek» Forums » Everything Else » Chit Chat

Subject: It's Tech Support Time Again rss

Your Tags: Add tags
Popular Tags: [View All]
Eric "Shippy McShipperson" Mowrer
United States
Vancouver
Washington
flag msg tools
badge
Ami. Geek.
Avatar
mbmbmbmbmb
I was just given an EVGA GeForce 8800 GTX graphics card by a coworker. Long story short, two new PSUs later, I've got it up and running.

My current problem is that when it came up, Vista saw my monitor as a generic non-PnP monitor. It's max resolution is 1024x768. I've been running this monitor at 1440x900 for the last several years, so I know it can support higher resolutions.

I downloaded drivers from some third party site for the exact monitor I have (Envision g19lwk) because their main site is broken (never a good sign). I downloaded the latest non-beta drivers for GeForce 8800 GTX. Both installed successfully. Sweet, I can go in and change the resolution now, right? Nope. No dice. Any ideas of things to try?

ejm
3 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Robert Wesley
Nepal
Aberdeen
Washington
flag msg tools
designer
badge
Avatar
mb
robot Try it in "NOT VISTA" and see what happens, since there's your 'problem' to begin with! surprise
2 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Xander Fulton
United States
Astoria
Oregon
flag msg tools
designer
badge
Avatar
mbmbmbmbmb
Hmmmm. That USUALLY indicates a problem with the video card drivers. (I assume you rebooted after installing the drivers, right? Not a requirement for most driver updates any more, but for the first install...sometimes)

Did the drivers install correctly? IE., if you open up device manager (in control panel), you have a 'Display Adapter' listed that is named something vaguely like 'NVIDIA Geforce 8800 GTX' or something like that?

Also - silly question, but...what video card did you have in the system before? Was it something onboard, or possibly an ATI/AMD card? If so, there may be some relics of those drivers hanging around causing issues.
4 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Eric "Shippy McShipperson" Mowrer
United States
Vancouver
Washington
flag msg tools
badge
Ami. Geek.
Avatar
mbmbmbmbmb
Yes, I rebooted a few times by now. The drivers for the monitor and GPU installed correctly with no warnings or errors and are recognized by the OS, at least on paper (correct labels).

Old card was a Pny GeForce 7600 GS.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Xander Fulton
United States
Astoria
Oregon
flag msg tools
designer
badge
Avatar
mbmbmbmbmb
ejmowrer wrote:
Yes, I rebooted a few times by now. The drivers for the monitor and GPU installed correctly with no warnings or errors and are recognized by the OS, at least on paper (correct labels).

Old card was a Pny GeForce 7600 GS.


What does GPU-Z say is the state of the card - connection details/width, etc?
2 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Eric "Shippy McShipperson" Mowrer
United States
Vancouver
Washington
flag msg tools
badge
Ami. Geek.
Avatar
mbmbmbmbmb
I'd love to tell you, but now I get nothing but a blank screen after installing the latest beta drivers for the GPU.

Also, something I didn't think was initially important, but may be related is that I wasn't seeing the post screen before. I didn't get anything until about the time the windows login screen came up.

When I get home, I'm going to take the card out and see if I can get back to something stable and then start over, this time making sure BIOS settings are correct before I try to fix the resolution issue.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Matt Riddle
United States
Oxford
Michigan
flag msg tools
designer
badge
Avatar
mbmbmbmbmb
Great card
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Eric "Shippy McShipperson" Mowrer
United States
Vancouver
Washington
flag msg tools
badge
Ami. Geek.
Avatar
mbmbmbmbmb
Interesting development here. Decided to go back to old setup and start fresh as per the above. Now I put the old card back, which supports VGA and DVI cables. With the VGA cable, everything is fine and it works as expected. With the DVI cable, I'm back to the same old problem. So I think it's safe to say that the problem doesn't lie with the new graphics card. The new card unfortunately only supports DVI. So... I'm off to the store to see if I can get a couple of adapters to play with and troubleshoot further. Maybe I can get it working with DVI -> VGA adaptor or maybe a new DVI cable (in the off chance my cable is somehow bad). I suspect the monitor is just not happy with its digital video input setting.

Continued advice apprecitated!
2 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Eric "Shippy McShipperson" Mowrer
United States
Vancouver
Washington
flag msg tools
badge
Ami. Geek.
Avatar
mbmbmbmbmb
Yeah, that's it. The only thing I don't know now is if this is a hardware problem or a software problem. It's definitely my monitor. It hates the DVI port for some reason.

Tried out Civ V with all video options cranked up and it's been smooth sailing so far.

Thanks for the help!

Never knew about GPU-Z before. Now I do. I'll remember that one even though it didn't turn out to be the card.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Xander Fulton
United States
Astoria
Oregon
flag msg tools
designer
badge
Avatar
mbmbmbmbmb
Well, DVI is *usually* the best format to use - if you've seen a DVI picture, it'd be hard to go back to analog. So it's probably worth fighting with a little more.

In the nVidia control panel, Display -> Change Resolution, you'll notice that you can select the resolution as well as color depth and refresh rate. For DVI, you'll want to make sure you are using 60hz and 32-bit color depth...see if the resolution you want appears in the list, then. You can also click the 'Customize' button, and with the 'enable resolutions not exposed by the display' checked, manually set any resolution you want.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Eric "Shippy McShipperson" Mowrer
United States
Vancouver
Washington
flag msg tools
badge
Ami. Geek.
Avatar
mbmbmbmbmb
XanderF wrote:
Well, DVI is *usually* the best format to use - if you've seen a DVI picture, it'd be hard to go back to analog. So it's probably worth fighting with a little more.

In the nVidia control panel, Display -> Change Resolution, you'll notice that you can select the resolution as well as color depth and refresh rate. For DVI, you'll want to make sure you are using 60hz and 32-bit color depth...see if the resolution you want appears in the list, then. You can also click the 'Customize' button, and with the 'enable resolutions not exposed by the display' checked, manually set any resolution you want.


I understand it's the best format, it just isn't working. I tried all of that stuff. The only resolutions available using the DVI port are 800x600 and 1024x786, and custom will not go beyond that. The correct drivers are installed for both the monitor and the graphics card (both cards). I believe the monitor is defective. Two different DVI cables gave the same result. Two different graphics cards gave the same result.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Front Page | Welcome | Contact | Privacy Policy | Terms of Service | Advertise | Support BGG | Feeds RSS
Geekdo, BoardGameGeek, the Geekdo logo, and the BoardGameGeek logo are trademarks of BoardGameGeek, LLC.